<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns#"><head><link rel="stylesheet" href="//fonts.googleapis.com/css?family=Roboto%3A300%2C400%7CRaleway%3A400%2C500%2C900" /><link rel='stylesheet' id='jquery-ui-style-css' href='https://cdnjs.cloudflare.com/ajax/libs/jqueryui/1.12.1/jquery-ui.min.css?ver=4.9.8' type='text/css' media='all' /><link rel='stylesheet' id='bootstrap-style-css' href='//cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.6/css/bootstrap.css?ver=3.2.10' type='text/css' media='all' /><link rel="stylesheet" href="https://www.blownmortgage.com/wp-content/cache/min/1/ad649a4e4613e5aa69e60ddb1f3ad94c.css" data-minify="1" /><script type='text/javascript' src='https://www.blownmortgage.com/wp-content/cache/busting/1/wp-includes-js-jquery-jquery-1.12.4.js'></script><script type='text/javascript' src='https://www.google.com/recaptcha/api.js?onload=recaptchaCallback&#038;render=explicit&#038;ver=2.0' defer></script><script src="https://www.blownmortgage.com/wp-content/cache/min/1/718c59f1db4267f6509adee5df50788b.js" data-minify="1" defer></script> <meta charset="UTF-8" /><title>Steps to Buying a House With Bad Credit - Blown Mortgage</title><meta name="viewport" content="width=device-width, initial-scale=1" /><meta name="description" content="It is possible to get a mortgage with bad credit. Follow the steps in this guide to get started." /><link rel="canonical" href="https://www.blownmortgage.com/steps-buying-house-bad-credit/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Steps to Buying a House With Bad Credit - Blown Mortgage" /><meta property="og:description" content="It is possible to get a mortgage with bad credit. Follow the steps in this guide to get started." /><meta property="og:url" content="https://www.blownmortgage.com/steps-buying-house-bad-credit/" /><meta property="og:site_name" content="Blown Mortgage" /><meta property="article:section" content="Mortgage News/Insight" /><meta property="article:published_time" content="2018-11-19T09:01:44-07:00" /><meta property="article:modified_time" content="2018-10-24T09:10:51-07:00" /><meta property="og:updated_time" content="2018-10-24T09:10:51-07:00" /><meta property="og:image" content="https://www.blownmortgage.com/wp-content/uploads/2018/10/Steps-to-Buying-a-House-With-Bad-Credit.jpg" /><meta property="og:image:secure_url" content="https://www.blownmortgage.com/wp-content/uploads/2018/10/Steps-to-Buying-a-House-With-Bad-Credit.jpg" /><meta property="og:image:width" content="900" /><meta property="og:image:height" content="471" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="It is possible to get a mortgage with bad credit. Follow the steps in this guide to get started." /><meta name="twitter:title" content="Steps to Buying a House With Bad Credit - Blown Mortgage" /><meta name="twitter:site" content="@jmchood" /><meta name="twitter:image" content="https://www.blownmortgage.com/wp-content/uploads/2018/10/Steps-to-Buying-a-House-With-Bad-Credit.jpg" /><meta name="twitter:creator" content="@jmchood" /> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/www.blownmortgage.com\/","name":"Blown Mortgage","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.blownmortgage.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Blown Mortgage &raquo; Feed" href="https://www.blownmortgage.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Blown Mortgage &raquo; Comments Feed" href="https://www.blownmortgage.com/comments/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><!--[if lt IE 9]> <script type='text/javascript' src='https://www.blownmortgage.com/wp-content/themes/genesis/lib/js/html5shiv.js?ver=3.7.3' defer></script> <![endif]--><link rel='https://api.w.org/' href='https://www.blownmortgage.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.blownmortgage.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.blownmortgage.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.blownmortgage.com/?p=9201' /> <script type="text/javascript">var ajaxurl = 'https://www.blownmortgage.com/wp-admin/admin-ajax.php';</script> <link rel="icon" href="https://www.blownmortgage.com/wp-content/themes/magazine-pro/images/favicon.ico" /> <script src=\"http://mortgage.info/_w/chart.js\" type=\"text/javascript\"></script> <script src=\"http://mortgage.info/_w/mortgage-calculator.js?v=1.0\" type=\"text/javascript\"></script> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-53410608-1', 'auto');
  ga('send', 'pageview');</script> <script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','//connect.facebook.net/en_US/fbevents.js');

fbq('init', '605940709573589');
fbq('track', "PageView");</script> <noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=605940709573589&ev=PageView&noscript=1"/></noscript> <script>!function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '1556684911106081');
  fbq('track', 'PageView');</script> <noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1556684911106081&ev=PageView&noscript=1"
/></noscript><div id="contact-us" class="modal fade" role="dialog"><div class="modal-dialog"><div class="modal-content"><div class="modal-header"> <button type="button" class="close" data-dismiss="modal">&times;</button><h4 class="modal-title">Contact Us</h4></div><div class="modal-body"><div role="form" class="wpcf7" id="wpcf7-f8830-o1" lang="en-US" dir="ltr"><div class="screen-reader-response"></div><form action="/steps-buying-house-bad-credit/#wpcf7-f8830-o1" method="post" class="wpcf7-form" novalidate="novalidate"><div style="display: none;"> <input type="hidden" name="_wpcf7" value="8830" /> <input type="hidden" name="_wpcf7_version" value="5.0.2" /> <input type="hidden" name="_wpcf7_locale" value="en_US" /> <input type="hidden" name="_wpcf7_unit_tag" value="wpcf7-f8830-o1" /> <input type="hidden" name="_wpcf7_container_post" value="0" /></div><div class="contact-us-form-wrapper"><div class="response"><div class="wpcf7-response-output wpcf7-display-none"></div></div><div class="contact-us-form"><div class="form-grp"> <label class="field-label">First Name*:</label><span class="wpcf7-form-control-wrap first-name"><input type="text" name="first-name" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-validates-as-required" aria-required="true" aria-invalid="false" /></span></div><div class="form-grp"> <label class="field-label">Last Name*:</label><span class="wpcf7-form-control-wrap last-name"><input type="text" name="last-name" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-validates-as-required" aria-required="true" aria-invalid="false" /></span></div><div class="form-grp"> <label class="field-label">Email*:</label><span class="wpcf7-form-control-wrap contact-email"><input type="email" name="contact-email" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-email wpcf7-validates-as-required wpcf7-validates-as-email" aria-required="true" aria-invalid="false" /></span></div><div class="form-grp"> <label class="field-label">Reason for Contacting*:</label><span class="wpcf7-form-control-wrap reason_for_contacting"><select name="reason_for_contacting" class="wpcf7-form-control wpcf7-select wpcf7-validates-as-required" aria-required="true" aria-invalid="false"><option value="">Select One</option><option value="Connect me with a lender">Connect me with a lender</option><option value="Please send more information">Please send more information</option><option value="Problem with your site">Problem with your site</option><option value="I would like to unsubscribe">I would like to unsubscribe</option><option value="Other">Other</option></select></span><span class="chevron"></span></div><div class="form-grp"> <label class="field-label">Message*:</label><span class="wpcf7-form-control-wrap contact-message"><textarea name="contact-message" cols="40" rows="10" class="wpcf7-form-control wpcf7-textarea wpcf7-validates-as-required" aria-required="true" aria-invalid="false"></textarea></span></div><div class="form-grp"><div class="wpcf7-form-control-wrap"><div data-sitekey="6Lf1K2UUAAAAAJsYYEbszpabnAqFsFU9unv3fFk5" class="wpcf7-form-control g-recaptcha wpcf7-recaptcha"></div> <noscript><div style="width: 302px; height: 422px;"><div style="width: 302px; height: 422px; position: relative;"><div style="width: 302px; height: 422px; position: absolute;"> <iframe src="https://www.google.com/recaptcha/api/fallback?k=6Lf1K2UUAAAAAJsYYEbszpabnAqFsFU9unv3fFk5" frameborder="0" scrolling="no" style="width: 302px; height:422px; border-style: none;"> </iframe></div><div style="width: 300px; height: 60px; border-style: none; bottom: 12px; left: 25px; margin: 0px; padding: 0px; right: 25px; background: #f9f9f9; border: 1px solid #c1c1c1; border-radius: 3px;"><textarea id="g-recaptcha-response" name="g-recaptcha-response" class="g-recaptcha-response" style="width: 250px; height: 40px; border: 1px solid #c1c1c1; margin: 10px 25px; padding: 0px; resize: none;">
				</textarea></div></div></div> </noscript></div></div><div class="form-grp"><div class="submit-close-wrapper"><div class="sc-cont"><input type="submit" value="Submit" class="wpcf7-form-control wpcf7-submit" /></div><div class="sc-cont"> <button type="button" class="btn btn-default" data-dismiss="modal">Close</button></div></p></div></p></div></p></div></div></form></div></div></div></div></div> <script type=\"text/javascript\" src=\"/wp-content/themes/blownmortgage/js/placeholder.js\"></script> <link rel=\"alternate\" type=\"application/rss+xml\" title=\"RSS Feeds For BlownMortgage.com\" href=\"http://www.blownmortgage.com/feed \" /><meta name=\"apple-itunes-app\" content=\"app-id=999002452\"><link rel=\"stylesheet\" href=\"https://maxcdn.bootstrapcdn.com/font-awesome/4.4.0/css/font-awesome.min.css\"><style>.lidd-mc-slider .ui-widget-content{border:1px
solid #c5c5c5}</style><style type="text/css">.site-title
a{background:url(https://www.blownmortgage.com/wp-content/uploads/2018/10/BlownMortgage-Logo.png) no-repeat !important}</style> <script data-no-minify="1" data-cfasync="false">(function(w,d){function a(){var b=d.createElement("script");b.async=!0;b.src="https://www.blownmortgage.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload.1.0.5.min.js";var a=d.getElementsByTagName("script")[0];a.parentNode.insertBefore(b,a)}w.attachEvent?w.attachEvent("onload",a):w.addEventListener("load",a,!1)})(window,document);</script></head><body class="post-template-default single single-post postid-9201 single-format-standard custom-header header-image content-sidebar primary-nav" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to content</a></li><li><a href="#genesis-nav-secondary" class="screen-reader-shortcut"> Skip to secondary menu</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li><li><a href="#genesis-footer-widgets" class="screen-reader-shortcut"> Skip to footer</a></li></ul><h2 class="screen-reader-text">Main navigation</h2><nav class="nav-primary" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary" aria-label="Main navigation"><div class="wrap"><ul id="menu-main-menu" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-5000" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5000"><a href="/" itemprop="url"><span itemprop="name">Home</span></a></li><li id="menu-item-4980" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4980"><a href="https://www.blownmortgage.com/about/" itemprop="url"><span itemprop="name">About</span></a><ul class="sub-menu"><li id="menu-item-4979" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4979"><a href="https://www.blownmortgage.com/contact-us/" itemprop="url"><span itemprop="name">Contact Us</span></a></li></ul></li><li id="menu-item-6396" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6396"><a target="_blank" href="http://trking10.com/?yte=wX5g43E7OqX%2F%2BPS02CAnhA%3D%3D&#038;s1=&#038;ts=content&#038;utm_source=Content%20-%20blownmortgage&#038;utm_medium=CTA%20Button%20Link&#038;utm_content=Orange" itemprop="url"><span itemprop="name">Mortgage Quote</span></a></li><li id="menu-item-4981" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4981"><a href="https://www.blownmortgage.com/rates/" itemprop="url"><span itemprop="name">Mortgage Rates</span></a></li><li id="menu-item-4726" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4726"><a href="#" itemprop="url"><span itemprop="name">Loan Programs</span></a><ul class="sub-menu"><li id="menu-item-6473" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6473"><a href="https://www.blownmortgage.com/down-payment-assistance-programs-are-available/" itemprop="url"><span itemprop="name">Down Payment Assistance</span></a></li><li id="menu-item-4983" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4983"><a href="https://www.blownmortgage.com/fha/" itemprop="url"><span itemprop="name">FHA</span></a><ul class="sub-menu"><li id="menu-item-4993" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4993"><a href="https://www.blownmortgage.com/fha/203k-loans/" itemprop="url"><span itemprop="name">203k Loans</span></a></li><li id="menu-item-4991" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4991"><a href="https://www.blownmortgage.com/fha/fha-streamline/" itemprop="url"><span itemprop="name">FHA Streamline Refinance</span></a></li></ul></li><li id="menu-item-4985" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4985"><a href="https://www.blownmortgage.com/va/" itemprop="url"><span itemprop="name">VA Home Loan Programs</span></a><ul class="sub-menu"><li id="menu-item-4992" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4992"><a href="https://www.blownmortgage.com/va/va-cash-out-refinance/" itemprop="url"><span itemprop="name">VA Cash Out Refinance</span></a></li></ul></li><li id="menu-item-4984" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4984"><a href="https://www.blownmortgage.com/harp/" itemprop="url"><span itemprop="name">HARP®</span></a></li><li id="menu-item-6708" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6708"><a href="https://www.blownmortgage.com/home-ready/" itemprop="url"><span itemprop="name">HomeReady™</span></a></li><li id="menu-item-6477" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6477"><a href="https://www.blownmortgage.com/conventional-loans/" itemprop="url"><span itemprop="name">Conventional</span></a></li><li id="menu-item-4988" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4988"><a href="https://www.blownmortgage.com/subprime/" itemprop="url"><span itemprop="name">Subprime</span></a></li><li id="menu-item-4986" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4986"><a href="https://www.blownmortgage.com/homepath/" itemprop="url"><span itemprop="name">HomePath®</span></a></li><li id="menu-item-4989" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4989"><a href="https://www.blownmortgage.com/usda-2/" itemprop="url"><span itemprop="name">USDA</span></a><ul class="sub-menu"><li id="menu-item-4990" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4990"><a href="https://www.blownmortgage.com/usda-2/streamline/" itemprop="url"><span itemprop="name">USDA Streamline Refinance</span></a></li></ul></li><li id="menu-item-6424" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6424"><a href="https://www.blownmortgage.com/reverse-mortgages/" itemprop="url"><span itemprop="name">Reverse Mortgages</span></a></li></ul></li><li id="menu-item-8070" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8070"><a href="https://www.blownmortgage.com/calculator/" itemprop="url"><span itemprop="name">Calculator</span></a></li><li id="menu-item-4982" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4982"><a href="https://www.blownmortgage.com/blog/" itemprop="url"><span itemprop="name">Blog</span></a></li></ul></div></nav><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://www.blownmortgage.com/">Blown Mortgage</a></p><p class="site-description" itemprop="description">First Time Home Buyer Programs | Home Loans | Refinance</p></div><div class="widget-area header-widget-area"><h2 class="genesis-sidebar-title screen-reader-text">Header Right</h2><section id="custom_html-2" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div class="hotline"><i class="fa fa-phone-square"></i> <span class="line-text">Mortgage Resource Specialist:</span> <a href="tel:8886066856">888-606-6856</a></div></div></div></section></div></div></header><nav class="nav-secondary" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-secondary"><div class="wrap"><ul id="menu-main-menu-1" class="menu genesis-nav-menu menu-secondary js-superfish"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5000"><a href="/" itemprop="url"><span itemprop="name">Home</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4980"><a href="https://www.blownmortgage.com/about/" itemprop="url"><span itemprop="name">About</span></a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4979"><a href="https://www.blownmortgage.com/contact-us/" itemprop="url"><span itemprop="name">Contact Us</span></a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6396"><a target="_blank" href="http://trking10.com/?yte=wX5g43E7OqX%2F%2BPS02CAnhA%3D%3D&#038;s1=&#038;ts=content&#038;utm_source=Content%20-%20blownmortgage&#038;utm_medium=CTA%20Button%20Link&#038;utm_content=Orange" itemprop="url"><span itemprop="name">Mortgage Quote</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4981"><a href="https://www.blownmortgage.com/rates/" itemprop="url"><span itemprop="name">Mortgage Rates</span></a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4726"><a href="#" itemprop="url"><span itemprop="name">Loan Programs</span></a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6473"><a href="https://www.blownmortgage.com/down-payment-assistance-programs-are-available/" itemprop="url"><span itemprop="name">Down Payment Assistance</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4983"><a href="https://www.blownmortgage.com/fha/" itemprop="url"><span itemprop="name">FHA</span></a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4993"><a href="https://www.blownmortgage.com/fha/203k-loans/" itemprop="url"><span itemprop="name">203k Loans</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4991"><a href="https://www.blownmortgage.com/fha/fha-streamline/" itemprop="url"><span itemprop="name">FHA Streamline Refinance</span></a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4985"><a href="https://www.blownmortgage.com/va/" itemprop="url"><span itemprop="name">VA Home Loan Programs</span></a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4992"><a href="https://www.blownmortgage.com/va/va-cash-out-refinance/" itemprop="url"><span itemprop="name">VA Cash Out Refinance</span></a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4984"><a href="https://www.blownmortgage.com/harp/" itemprop="url"><span itemprop="name">HARP®</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6708"><a href="https://www.blownmortgage.com/home-ready/" itemprop="url"><span itemprop="name">HomeReady™</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6477"><a href="https://www.blownmortgage.com/conventional-loans/" itemprop="url"><span itemprop="name">Conventional</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4988"><a href="https://www.blownmortgage.com/subprime/" itemprop="url"><span itemprop="name">Subprime</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4986"><a href="https://www.blownmortgage.com/homepath/" itemprop="url"><span itemprop="name">HomePath®</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4989"><a href="https://www.blownmortgage.com/usda-2/" itemprop="url"><span itemprop="name">USDA</span></a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4990"><a href="https://www.blownmortgage.com/usda-2/streamline/" itemprop="url"><span itemprop="name">USDA Streamline Refinance</span></a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6424"><a href="https://www.blownmortgage.com/reverse-mortgages/" itemprop="url"><span itemprop="name">Reverse Mortgages</span></a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8070"><a href="https://www.blownmortgage.com/calculator/" itemprop="url"><span itemprop="name">Calculator</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4982"><a href="https://www.blownmortgage.com/blog/" itemprop="url"><span itemprop="name">Blog</span></a></li></ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><article class="post-9201 post type-post status-publish format-standard has-post-thumbnail category-mortgage-newsinsight entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Steps to Buying a House With Bad Credit</h1><p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2018-11-19T09:01:44+00:00">November 19, 2018</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://www.blownmortgage.com/author/jmchood/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">JMcHood</span></a></span></p></header><div class="entry-content" itemprop="text"><p><img class="alignnone size-full wp-image-9205" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.blownmortgage.com/wp-content/uploads/2018/10/Steps-to-Buying-a-House-With-Bad-Credit.jpg" alt="" width="900" height="471" data-lazy-srcset="https://www.blownmortgage.com/wp-content/uploads/2018/10/Steps-to-Buying-a-House-With-Bad-Credit.jpg 900w, https://www.blownmortgage.com/wp-content/uploads/2018/10/Steps-to-Buying-a-House-With-Bad-Credit-300x157.jpg 300w, https://www.blownmortgage.com/wp-content/uploads/2018/10/Steps-to-Buying-a-House-With-Bad-Credit-768x402.jpg 768w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" /><noscript><img class="alignnone size-full wp-image-9205" src="https://www.blownmortgage.com/wp-content/uploads/2018/10/Steps-to-Buying-a-House-With-Bad-Credit.jpg" alt="" width="900" height="471" srcset="https://www.blownmortgage.com/wp-content/uploads/2018/10/Steps-to-Buying-a-House-With-Bad-Credit.jpg 900w, https://www.blownmortgage.com/wp-content/uploads/2018/10/Steps-to-Buying-a-House-With-Bad-Credit-300x157.jpg 300w, https://www.blownmortgage.com/wp-content/uploads/2018/10/Steps-to-Buying-a-House-With-Bad-Credit-768x402.jpg 768w" sizes="(max-width: 900px) 100vw, 900px" /></noscript></p><p>If you have bad credit, it doesn’t have to keep you from buying a home. Many lenders offer programs for people just like you. With the following steps, you can make the American Dream of owning a home part of your reality.</p><p> <a href="http://trking10.com/?yte=wX5g43E7OqX%2F%2BPS02CAnhA%3D%3D&s1=&ts=content&utm_source=Content%20-%20blownmortgage&utm_medium=Body%20Text%20Link" class="cta-button-link">Get Matched with a Lender, Click Here.</a></p><h2>Increase Your Credit Score</h2><p>The first step is obvious. You should try to increase your credit score as much as you can. This starts with checking your credit report for accuracy. You should also look for little things you can fix. You can head <a target="_blank" href="https://www.annualcreditreport.com/index.action">here</a> to get a free copy of your credit report from each of the three bureaus.</p><p>Once you have one or more of your credit reports, look at the information reported. Is everything accurate? If you find any errors, dispute them with the credit bureau right away. If you send the request in writing and provide proof of why you think it’s a mistake, the credit bureau has 30 days to resolve the issue. If the creditor doesn’t respond to the credit bureau within that time, the credit bureau must delete the misinformation from your credit report.</p><p>If you find the information reported is correct, but it’s something you can fix, go for it. For example, if you have late payments, bring them current. If you have large credit card balances, try to pay them down or even off in full if you can.</p><p>Whatever you do, don’t close any credit card accounts or open new accounts during this time, though. Either of these could lower your credit score even more.</p><h2>Save Money for a Down Payment</h2><p>If you have bad credit, chances are that you aren’t going to find a ‘no down payment’ loan. Instead, you will run into lenders that want a sizeable down payment. Start saving for this as early as you can because the more money you have to put down on a home, the higher your chances of approval become.</p><p>We aren’t saying you need 20% down or you won’t get a mortgage. What we are saying is that the more money you have available, the higher your chances of getting a lower interest rate and better term become. Lenders want to know that you have some investment in the home. If you have ‘bad credit,’ you already pose a high risk to a lender. They want some compensating factors to make up for that risk in order to give you a loan.</p><p>Every lender will differ in the amount of the down payment they require. You may find loans provided by lenders for borrowers with bad credit that only require a few thousand dollars down, though. It’s up to you to figure out which loan works the best in your situation.</p><h2>Lower Your Debt Ratio</h2><p>Again, because you have a low credit score, you want to make the rest of your application look as attractive as possible. This includes your debt ratio. Because you will likely use a portfolio lender, there isn’t a specific debt ratio that you need. In general, though, you want it as low as possible.</p><p>You’ll have two debt ratios – your housing ratio and your total debt ratio. The housing ratio is the comparison of your new housing payment to your gross monthly income. Your total debt ratio is the number you have control over at the moment. It compares your total debt to your gross monthly income.</p><p>Your total debt includes minimum credit card payments, monthly installment payments, and your new housing payment. Keeping those credit card balances to a minimum will help lower this ratio, giving you a better chance at securing a mortgage.</p><p> <a href="http://trking10.com/?yte=wX5g43E7OqX%2F%2BPS02CAnhA%3D%3D&s1=&ts=content&utm_source=Content%20-%20blownmortgage&utm_medium=Body%20Text%20Link" class="cta-button-link">Click to See the Latest Mortgage Rates.</a></p><h2>Shop for Portfolio Lenders</h2><p>Here’s the tricky part. You aren’t going to find your standard conventional or FHA lenders. If your credit score is too low, you won’t qualify for these programs. Although don’t discount the value of the FHA loan. Technically, you only need a 580 credit score to get an FHA loan. But you need other qualifying factors too. Some FHA lenders require slightly higher credit scores too, especially since they can offer you a loan with as little as 3.5% down on the home.</p><p>Portfolio lenders keep the loans on their books. What does this mean for you? There aren’t any secondary investors. In other words, no one else has a say in which requirements you need to get the loan. This can be great news for you, especially if you find a lender that will take a credit score as low as yours is at the moment.</p><p>Make sure you shop online, in person, and maybe even with a mortgage broker. You should know all of your options as portfolio lenders are everywhere. You aren’t going to see their products advertised as much as you’ll see the standard FHA and conventional loans advertised, though. This is why you’ll have to do some legwork and digging to get the loan you need.</p><h2>Get Pre-Approved and Choose a Lender</h2><p>The final step in securing a mortgage with bad credit is to get pre-approvals from the lenders you have found. You won’t know which lender will suit you the most until you see the details of the loan. Each lender must provide you with a Loan Estimate, which includes the potential loan amount, interest rate, payment, APR, and closing costs.</p><p>Sit down and compare the Loan Estimates to one another. Which one suits your needs the most? Don’t focus strictly on the interest rate. Look at the big picture. How much does each loan cost you over its lifetime? Which loan has the most affordable payment while keeping your costs on the lower end in the end?</p><p>Once you choose a lender, you can move forward with their process. At this point, you can start shopping for a home because you know how much loan you can afford and what a lender will give you.</p><p>Keep in mind that preapprovals are usually good for 30 – 60 days, so keep on looking for a home, and stay in contact with your lender in the meantime. If your preapproval expires, you’ll have to go through the preapproval process all over again in order to ensure that you are still qualified for the loan.</p><p>Getting a mortgage with bad credit isn’t as hard as it seems. Lenders have loosened their guidelines and more portfolio lenders are popping up every day. Be diligent in your search and find the lender that will give you the loan that makes the most sense for you.</p><p> <a href="http://trking10.com/?yte=wX5g43E7OqX%2F%2BPS02CAnhA%3D%3D&s1=&ts=content&utm_source=Content%20-%20blownmortgage&utm_medium=Body%20Text%20Link" class="cta-button-link"><span class="">Click Here to Get Matched With a Lender.</span></a></p> <span id="tve_leads_end_content" style="display: block; visibility: hidden; border: 1px solid transparent;"></span> <a href="http://trking10.com/?yte=wX5g43E7OqX%2F%2BPS02CAnhA%3D%3D&s1=&ts=content&utm_source=Content%20-%20blownmortgage&utm_medium=CTA%20Button%20Link&utm_content=Orange" class="button-orange"><span class="">Click to See the Latest Mortgage Rates»</span></a></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://www.blownmortgage.com/category/mortgage-newsinsight/" rel="category tag">Mortgage News/Insight</a></span></p></footer></article></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="text-2" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><a href="http://trking10.com/?yte=wX5g43E7OqX%2F%2BPS02CAnhA%3D%3D&s1=&ts=content&utm_source=Content%20-%20blownmortgage&utm_medium=CTA%20Banner%20Link"><img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="/wp-content/uploads/2015/03/quotes-sidebar.jpg" /><noscript><img src="/wp-content/uploads/2015/03/quotes-sidebar.jpg" /></noscript></a></div></div></section> <section id="lidd_mc_widget-3" class="widget widget_lidd_mc_widget"><div class="widget-wrap"><h3 class="widgettitle widget-title">Mortgage Loans</h3><form action="https://www.blownmortgage.com/steps-buying-house-bad-credit/#lidd_mc_form" id="lidd_mc_form" class="lidd_mc_form lidd-mc-slider" method="post"><div class="lidd_mc_input lidd_mc_input_light lidd_mc_input_responsive"><label for="lidd_mc_total_amount">Total Amount</label><div id="lidd_mc_total_amount_value" for="lidd_mc_total_amount"><div class="lidd_mc_total_amount_currency_value">$<span class="lidd_mc_total_amount_label">250,000</span></div></div><div id="lidd_mc_total_amount_slider" for="lidd_mc_total_amount"></div><input type="hidden" name="lidd_mc_total_amount" id="lidd_mc_total_amount" value="250000" data-value="250000" /><span id="lidd_mc_total_amount-error"></span></div><div class="lidd_mc_input lidd_mc_input_light lidd_mc_input_responsive"><label for="lidd_mc_down_payment">Down Payment</label><div id="lidd_mc_down_payment_value" for="lidd_mc_down_payment"><div class="lidd_mc_down_payment_currency_value">$<span class="lidd_mc_down_payment_label">25,000</span></div></div><div id="lidd_mc_down_payment_slider" for="lidd_mc_down_payment"></div><input type="hidden" name="lidd_mc_down_payment" id="lidd_mc_down_payment" value="25000" data-value="25000" /><span id="lidd_mc_down_payment-error"></span></div><div class="lidd_mc_input lidd_mc_input_light lidd_mc_input_responsive"><label for="lidd_mc_interest_rate">Interest Rate</label><div id="lidd_mc_interest_rate_value" for="lidd_mc_interest_rate"><div class="lidd_mc_interest_rate_interest_value"><div class="lidd_mc_interest_rate_value interest_value_symbol">5.00</div><div class="lidd_mc_interest_rate_interest interest_value_symbol">%</div></div></div><div id="lidd_mc_interest_rate_slider" for="lidd_mc_interest_rate"></div><input type="hidden" name="lidd_mc_interest_rate" id="lidd_mc_interest_rate" value="5.00" data-value="5.00" /><span id="lidd_mc_interest_rate-error"></span></div><div class="lidd_mc_input amortization_period_years lidd_mc_input_light lidd_mc_input_responsive"><label for="lidd_mc_amortization_period">Loan Term</label><div id="lidd_mc_amortization_period_value" for="lidd_mc_amortization_period"><div class="lidd_mc_amortization_period_amortization"><div class="lidd_mc_amortization_period_value amortization_value">5</div><div class="lidd_mc_amortization_period_interest amortization_value">Years</div></div></div><div id="lidd_mc_amortization_period_slider" for="lidd_mc_amortization_period"></div><input type="hidden" name="lidd_mc_amortization_period" id="lidd_mc_amortization_period" value="5" data-value="5" /><span id="lidd_mc_amortization_period-error"></span></div><input type="hidden" name="lidd_mc_payment_period" id="lidd_mc_payment_period" value="12" /><div class="lidd_mc_input"><input type="submit" name="lidd_mc_submit" id="lidd_mc_submit" value="Calculate" /></div></form><div id="lidd_mc_details" class="lidd_mc_details" style="display: none;"><div id="lidd_mc_results" class="lidd_mc_results"></div><div id="lidd_mc_learn_more" class="lidd_mc_results"><a id="lidd_mc_lear_more_link" href="https://www.blownmortgage.com/calculator/" target="_blank" data-link="https://www.blownmortgage.com/calculator/">Learn More</a></div><img id="lidd_mc_inspector" src="https://www.blownmortgage.com/wp-content/plugins/responsive-mortgage-calculator/img/icon_inspector.png" alt="Details" /><div id="lidd_mc_summary" class="lidd_mc_summary lidd_mc_summary_light" style="display: none;"></div></div></div></section> <section id="recent-posts-widget-with-thumbnails-3" class="widget recent-posts-widget-with-thumbnails"><div class="widget-wrap"><div id="rpwwt-recent-posts-widget-with-thumbnails-3" class="rpwwt-widget"><h3 class="widgettitle widget-title">Recent Posts</h3><ul><li><a href="https://www.blownmortgage.com/conditional-approval-pre-approval/"><img width="75" height="75" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.blownmortgage.com/wp-content/uploads/2018/10/Is-a-Conditional-Approval-the-Same-as-a-Pre-Approval-100x100.jpg" class="attachment-75x75 size-75x75 wp-post-image" alt="Boy" data-lazy-srcset="https://www.blownmortgage.com/wp-content/uploads/2018/10/Is-a-Conditional-Approval-the-Same-as-a-Pre-Approval-100x100.jpg 100w, https://www.blownmortgage.com/wp-content/uploads/2018/10/Is-a-Conditional-Approval-the-Same-as-a-Pre-Approval-150x150.jpg 150w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" /><noscript><img width="75" height="75" src="https://www.blownmortgage.com/wp-content/uploads/2018/10/Is-a-Conditional-Approval-the-Same-as-a-Pre-Approval-100x100.jpg" class="attachment-75x75 size-75x75 wp-post-image" alt="Boy" srcset="https://www.blownmortgage.com/wp-content/uploads/2018/10/Is-a-Conditional-Approval-the-Same-as-a-Pre-Approval-100x100.jpg 100w, https://www.blownmortgage.com/wp-content/uploads/2018/10/Is-a-Conditional-Approval-the-Same-as-a-Pre-Approval-150x150.jpg 150w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">Is a Conditional Approval the Same as a Pre-Approval?</span></a></li><li><a href="https://www.blownmortgage.com/avoid-paying-pmi-fha-loan/"><img width="75" height="75" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.blownmortgage.com/wp-content/uploads/2018/10/How-to-Avoid-Paying-PMI-With-an-FHA-Loan-100x100.jpg" class="attachment-75x75 size-75x75 wp-post-image" alt="Dining table" data-lazy-srcset="https://www.blownmortgage.com/wp-content/uploads/2018/10/How-to-Avoid-Paying-PMI-With-an-FHA-Loan-100x100.jpg 100w, https://www.blownmortgage.com/wp-content/uploads/2018/10/How-to-Avoid-Paying-PMI-With-an-FHA-Loan-150x150.jpg 150w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" /><noscript><img width="75" height="75" src="https://www.blownmortgage.com/wp-content/uploads/2018/10/How-to-Avoid-Paying-PMI-With-an-FHA-Loan-100x100.jpg" class="attachment-75x75 size-75x75 wp-post-image" alt="Dining table" srcset="https://www.blownmortgage.com/wp-content/uploads/2018/10/How-to-Avoid-Paying-PMI-With-an-FHA-Loan-100x100.jpg 100w, https://www.blownmortgage.com/wp-content/uploads/2018/10/How-to-Avoid-Paying-PMI-With-an-FHA-Loan-150x150.jpg 150w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Avoid Paying PMI With an FHA Loan</span></a></li><li><a href="https://www.blownmortgage.com/much-termite-inspection-cost/"><img width="75" height="75" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.blownmortgage.com/wp-content/uploads/2018/10/How-Much-Does-a-Termite-Inspection-Cost-100x100.jpg" class="attachment-75x75 size-75x75 wp-post-image" alt="Termite control" data-lazy-srcset="https://www.blownmortgage.com/wp-content/uploads/2018/10/How-Much-Does-a-Termite-Inspection-Cost-100x100.jpg 100w, https://www.blownmortgage.com/wp-content/uploads/2018/10/How-Much-Does-a-Termite-Inspection-Cost-150x150.jpg 150w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" /><noscript><img width="75" height="75" src="https://www.blownmortgage.com/wp-content/uploads/2018/10/How-Much-Does-a-Termite-Inspection-Cost-100x100.jpg" class="attachment-75x75 size-75x75 wp-post-image" alt="Termite control" srcset="https://www.blownmortgage.com/wp-content/uploads/2018/10/How-Much-Does-a-Termite-Inspection-Cost-100x100.jpg 100w, https://www.blownmortgage.com/wp-content/uploads/2018/10/How-Much-Does-a-Termite-Inspection-Cost-150x150.jpg 150w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How Much Does a Termite Inspection Cost?</span></a></li><li><a href="https://www.blownmortgage.com/fha-title-1-home-improvement-loan-guide/"><img width="75" height="75" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.blownmortgage.com/wp-content/uploads/2018/10/FHA-Title-1-Home-Improvement-Loan-Guide-100x100.jpg" class="attachment-75x75 size-75x75 wp-post-image" alt="Furnitures" data-lazy-srcset="https://www.blownmortgage.com/wp-content/uploads/2018/10/FHA-Title-1-Home-Improvement-Loan-Guide-100x100.jpg 100w, https://www.blownmortgage.com/wp-content/uploads/2018/10/FHA-Title-1-Home-Improvement-Loan-Guide-150x150.jpg 150w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" /><noscript><img width="75" height="75" src="https://www.blownmortgage.com/wp-content/uploads/2018/10/FHA-Title-1-Home-Improvement-Loan-Guide-100x100.jpg" class="attachment-75x75 size-75x75 wp-post-image" alt="Furnitures" srcset="https://www.blownmortgage.com/wp-content/uploads/2018/10/FHA-Title-1-Home-Improvement-Loan-Guide-100x100.jpg 100w, https://www.blownmortgage.com/wp-content/uploads/2018/10/FHA-Title-1-Home-Improvement-Loan-Guide-150x150.jpg 150w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">FHA Title 1 Home Improvement Loan Guide</span></a></li><li><a href="https://www.blownmortgage.com/fha-guidelines-regarding-non-occupant-co-borrowers/"><img width="75" height="75" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.blownmortgage.com/wp-content/uploads/2018/10/FHA-Guidelines-Regarding-Non-Occupant-Co-Borrowers-100x100.jpg" class="attachment-75x75 size-75x75 wp-post-image" alt="House" data-lazy-srcset="https://www.blownmortgage.com/wp-content/uploads/2018/10/FHA-Guidelines-Regarding-Non-Occupant-Co-Borrowers-100x100.jpg 100w, https://www.blownmortgage.com/wp-content/uploads/2018/10/FHA-Guidelines-Regarding-Non-Occupant-Co-Borrowers-150x150.jpg 150w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" /><noscript><img width="75" height="75" src="https://www.blownmortgage.com/wp-content/uploads/2018/10/FHA-Guidelines-Regarding-Non-Occupant-Co-Borrowers-100x100.jpg" class="attachment-75x75 size-75x75 wp-post-image" alt="House" srcset="https://www.blownmortgage.com/wp-content/uploads/2018/10/FHA-Guidelines-Regarding-Non-Occupant-Co-Borrowers-100x100.jpg 100w, https://www.blownmortgage.com/wp-content/uploads/2018/10/FHA-Guidelines-Regarding-Non-Occupant-Co-Borrowers-150x150.jpg 150w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">FHA Guidelines Regarding Non-Occupant Co-Borrowers</span></a></li></ul></div></div></section> <section id="widget_sp_image-3" class="widget widget_sp_image"><div class="widget-wrap"><h3 class="widgettitle widget-title">OUR EXPERTS SEEN ON</h3> <img width="179" height="304" alt="OUR EXPERTS SEEN ON" class="attachment-full aligncenter" style="max-width: 100%;" srcset="https://www.blownmortgage.com/wp-content/uploads/2017/09/sd-1.png 179w, https://www.blownmortgage.com/wp-content/uploads/2017/09/sd-1-177x300.png 177w" sizes="(max-width: 179px) 100vw, 179px" src="https://www.blownmortgage.com/wp-content/uploads/2017/09/sd-1.png" /></div></section> </aside></div></div><div class="footer-widgets" id="genesis-footer-widgets"><h2 class="genesis-sidebar-title screen-reader-text">Footer</h2><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="categories-3" class="widget widget_categories"><div class="widget-wrap"><h3 class="widgettitle widget-title">Categories</h3><form action="https://www.blownmortgage.com" method="get"><label class="screen-reader-text" for="cat">Categories</label><select name='cat' id='cat' class='postform'><option value='-1'>Select Category</option><option class="level-0" value="2336">203K</option><option class="level-0" value="3988">Appraisal</option><option class="level-0" value="2">Bailout</option><option class="level-0" value="3253">Buying a Home</option><option class="level-0" value="3">CDS</option><option class="level-0" value="4">Commercial real estate</option><option class="level-0" value="2370">Construction Loan</option><option class="level-0" value="5">Consumer Mortgage Tips</option><option class="level-0" value="6">Credit</option><option class="level-0" value="7">Debt Consolidation</option><option class="level-0" value="8">debt relief</option><option class="level-0" value="2400">Down Payment</option><option class="level-0" value="9">Economy</option><option class="level-0" value="3299">Energy Efficient Mortgages</option><option class="level-0" value="2388">Fannie Mae</option><option class="level-0" value="2795">Fannie Mae HomeReady™ Income</option><option class="level-0" value="10">FHA</option><option class="level-0" value="3747">First-Time Home Buyer</option><option class="level-0" value="2796">Fnma HomeReady™ Program Guidelines</option><option class="level-0" value="11">Foreclosure</option><option class="level-0" value="2382">Foreign National Loans</option><option class="level-0" value="3792">Freddie Mac</option><option class="level-0" value="12">Global Economy</option><option class="level-0" value="2413">Good Neighbor Next Door Program</option><option class="level-0" value="13">GSEs</option><option class="level-0" value="2797">Guidelines</option><option class="level-0" value="14">HARP®</option><option class="level-0" value="15">Hedge funds</option><option class="level-0" value="3170">HELOC</option><option class="level-0" value="3111">Homeownership</option><option class="level-0" value="16">Industry Mortgage Tips</option><option class="level-0" value="17">Insurance</option><option class="level-0" value="2792">Interest Rates</option><option class="level-0" value="3876">Investment Homes</option><option class="level-0" value="18">Job Search</option><option class="level-0" value="3914">Land</option><option class="level-0" value="19">Legislation</option><option class="level-0" value="20">Lenders</option><option class="level-0" value="21">Loan modification</option><option class="level-0" value="2366">Loan Process</option><option class="level-0" value="3325">Loan Types</option><option class="level-0" value="22">Market Update</option><option class="level-0" value="23">Marketing</option><option class="level-0" value="24">Mortgage Insurance</option><option class="level-0" value="25">Mortgage Links</option><option class="level-0" value="26">Mortgage Musings</option><option class="level-0" value="27">Mortgage News/Insight</option><option class="level-0" value="28">Podcasts</option><option class="level-0" value="2340">Pre-Payment</option><option class="level-0" value="29">Random Thoughts</option><option class="level-0" value="30">Reader Response</option><option class="level-0" value="31">Real Estate Musings</option><option class="level-0" value="2341">Refinancing</option><option class="level-0" value="2347">Renovation loans</option><option class="level-0" value="3879">Rent to Own</option><option class="level-0" value="2800">Rental Property Investing</option><option class="level-0" value="32">renters</option><option class="level-0" value="2151">Reverse Mortgages</option><option class="level-0" value="33">scandals</option><option class="level-0" value="3766">Self-Employed</option><option class="level-0" value="34">Sponsored</option><option class="level-0" value="2393">Stated Income</option><option class="level-0" value="35">Subprime</option><option class="level-0" value="1">Uncategorized</option><option class="level-0" value="3267">Underwriting</option><option class="level-0" value="36">USDA</option><option class="level-0" value="37">VA</option><option class="level-0" value="38">Wall Street</option><option class="level-0" value="39">We&#8217;re Reading</option><option class="level-0" value="40">Web/Tech</option><option class="level-0" value="41">Weblogs</option><option class="level-0" value="42">Why I Hate My Industry</option> </select></form> <script type='text/javascript'>/*  */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/*  */</script> </div></section></div><div class="widget-area footer-widgets-2 footer-widget-area"> <section id="recent-posts-4" class="widget widget_recent_entries"><div class="widget-wrap"><h3 class="widgettitle widget-title">Latest Posts</h3><ul><li> <a href="https://www.blownmortgage.com/steps-buying-house-bad-credit/">Steps to Buying a House With Bad Credit</a></li><li> <a href="https://www.blownmortgage.com/conditional-approval-pre-approval/">Is a Conditional Approval the Same as a Pre-Approval?</a></li><li> <a href="https://www.blownmortgage.com/avoid-paying-pmi-fha-loan/">How to Avoid Paying PMI With an FHA Loan</a></li><li> <a href="https://www.blownmortgage.com/much-termite-inspection-cost/">How Much Does a Termite Inspection Cost?</a></li><li> <a href="https://www.blownmortgage.com/fha-title-1-home-improvement-loan-guide/">FHA Title 1 Home Improvement Loan Guide</a></li><li> <a href="https://www.blownmortgage.com/fha-guidelines-regarding-non-occupant-co-borrowers/">FHA Guidelines Regarding Non-Occupant Co-Borrowers</a></li></ul></div></section></div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="search-4" class="widget widget_search"><div class="widget-wrap"><h3 class="widgettitle widget-title">Search</h3><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="https://www.blownmortgage.com/" role="search"><meta itemprop="target" content="https://www.blownmortgage.com/?s={s}" /><label class="search-form-label screen-reader-text" for="searchform-5bf34be436ca42.71570933">Search the site ...</label><input itemprop="query-input" type="search" name="s" id="searchform-5bf34be436ca42.71570933" placeholder="Search the site ..." /><input type="submit" value="Search" /></form></div></section></div></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><div class="footer_disclosure"><p><strong>IMPORTANT MORTGAGE DISCLOSURES:</strong></p><p>When inquiring about a mortgage on this site, this is not a mortgage application. Upon the completion of your inquiry, we will work hard to match you with a lender who may assist you with a mortgage application and provide mortgage product eligibility requirements for your individual situation.</p><p>Any mortgage product that a lender may offer you will carry fees or costs including closing costs, origination points, and/or refinancing fees. In many instances, fees or costs can amount to several thousand dollars and can be due upon the origination of the mortgage credit product.</p><p>When applying for a mortgage credit product, lenders will commonly require you to provide a valid social security number and submit to a credit check . Consumers who do not have the minimum acceptable credit required by the lender are unlikely to be approved for mortgage refinancing.</p><p>Minimum credit ratings may vary according to lender and mortgage product. In the event that you do not qualify for a credit rating based on the required minimum credit
rating, a lender may or may not introduce you to a credit counseling service or credit improvement company who may or may not be able to assist you with improving your credit for a fee.</p></div><p>Copyright &copy; <php echo date('Y');?> Mortgage.info is not a government agency or a lender. Not affiliated with HUD, FHA, VA, FNMA or GNMA. We work hard to match you with local lenders for the mortgage you inquire about. This is not an offer to lend and we are not affiliated with your current mortgage servicer.</p><p> <a data-toggle="modal" data-target="#contact-us" style="cursor:pointer;">Contact Us</a> | <a href="/terms-of-use/">Terms of Use</a> | <a href="/privacy-policy/">Privacy Policy</a> | <a href="/Media/">Media</a> | <a href="/dmca-policy/">DMCA Policy</a> | <a href="/anti-spam-policy/">Anti-spam Policy</a> | <a href="http://www.optout-jsql.net/o-jsql-g42-cf30594d08da4f44c3b50905f719fde0">Unsubscribe</a></p><p>Mortgage.info</p><p>NMLS ID #1237615 | AZMB #0928735</p><p>8123 South Interport Blvd. Suite A, Englewood, CO 80112</p></div></footer></div><script type="text/javascript">var recaptchaWidgets = [];
var recaptchaCallback = function() {
	var forms = document.getElementsByTagName( 'form' );
	var pattern = /(^|\s)g-recaptcha(\s|$)/;

	for ( var i = 0; i < forms.length; i++ ) {
		var divs = forms[ i ].getElementsByTagName( 'div' );

		for ( var j = 0; j < divs.length; j++ ) {
			var sitekey = divs[ j ].getAttribute( 'data-sitekey' );

			if ( divs[ j ].className && divs[ j ].className.match( pattern ) && sitekey ) {
				var params = {
					'sitekey': sitekey,
					'type': divs[ j ].getAttribute( 'data-type' ),
					'size': divs[ j ].getAttribute( 'data-size' ),
					'theme': divs[ j ].getAttribute( 'data-theme' ),
					'badge': divs[ j ].getAttribute( 'data-badge' ),
					'tabindex': divs[ j ].getAttribute( 'data-tabindex' )
				};

				var callback = divs[ j ].getAttribute( 'data-callback' );

				if ( callback && 'function' == typeof window[ callback ] ) {
					params[ 'callback' ] = window[ callback ];
				}

				var expired_callback = divs[ j ].getAttribute( 'data-expired-callback' );

				if ( expired_callback && 'function' == typeof window[ expired_callback ] ) {
					params[ 'expired-callback' ] = window[ expired_callback ];
				}

				var widget_id = grecaptcha.render( divs[ j ], params );
				recaptchaWidgets.push( widget_id );
				break;
			}
		}
	}
};

document.addEventListener( 'wpcf7submit', function( event ) {
	switch ( event.detail.status ) {
		case 'spam':
		case 'mail_sent':
		case 'mail_failed':
			for ( var i = 0; i < recaptchaWidgets.length; i++ ) {
				grecaptcha.reset( recaptchaWidgets[ i ] );
			}
	}
}, false );</script> <script type=\"text/javascript\">adroll_adv_id = \"UO2IYJJ6SBAQBE7XHZ5BYI\";
    adroll_pix_id = \"BZVUDBFBOFDOVA7MVWOWSI\";
    / OPTIONAL: provide email to improve user identification /
    / adroll_email = \"username@example.com\"; /
    (function () {
        var _onload = function(){
            if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
            if (!window.adroll_loaded){adroll_loaded=true;setTimeout(_onload, 50);return}
            var scr = document.createElement(\"script\");
            var host = ((\"https:\" == document.location.protocol) ? \"https://s.adroll.com\" : \"http://a.adroll.com\");
            scr.setAttribute(\'async\', \'true\');
            scr.type = \"text/javascript\";
            scr.src = host + \"/j/roundtrip.js\";
            ((document.getElementsByTagName(\'head\') || [null])[0] ||
                document.getElementsByTagName(\'script\')[0].parentNode).appendChild(scr);
        };
        if (window.addEventListener) {window.addEventListener(\'load\', _onload, false);}
        else {window.attachEvent(\'onload\', _onload)}
    }());</script> <script type='text/javascript'>/*  */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.blownmortgage.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/*  */</script> <script type='text/javascript'>/*  */
var lidd_mc_script_vars = {"currency":"$","currency_code":"","currency_format":"<b class=\"lidd_mc_b\">{currency}{amount} {code}<\/b>","number_format":"6","compounding_period":"12","minimum_total_amount":"0","zero_percent_interest":"0","amortization_period_units":"0","summary":"1","summary_interest":"1","summary_downpayment":"1","ta_error":"Please enter the total amount. ","dp_error":"Please enter a down payment amount or leave blank.","ir_error":"Please enter an interest rate.","ap_error":"Please enter an amortization period.","weekly":"Weekly","biweekly":"Bi-Weekly","monthly":"Monthly","quarterly":"Quarterly","semiannual":"Semi-Annual","yearly":"Yearly","weekly_payment":"Weekly Payment","biweekly_payment":"Bi-Weekly Payment","monthly_payment":"Monthly Payment","quarterly_payment":"Quarterly Payment","semiannual_payment":"Semi-Annual Payment","yearly_payment":"Yearly Payment","sy_text":"For a mortgage of <b class=\"lidd_mc_b\">{total_amount}<\/b> amortized over <b class=\"lidd_mc_b\">{amortization_years}<\/b> years, your <b class=\"lidd_mc_b\">{payment_period}<\/b> payment is","sym1_text":"For a mortgage of <b class=\"lidd_mc_b\">{total_amount}<\/b> amortized over <b class=\"lidd_mc_b\">{amortization_years}<\/b> years and <b class=\"lidd_mc_b\">1<\/b> month, your <b class=\"lidd_mc_b\">{payment_period}<\/b> payment is","sym_text":"For a mortgage of <b class=\"lidd_mc_b\">{total_amount}<\/b> amortized over <b class=\"lidd_mc_b\">{amortization_years}<\/b> years and <b class=\"lidd_mc_b\">{amortization_months}<\/b> months, your <b class=\"lidd_mc_b\">{payment_period}<\/b> payment is","syw1_text":"For a mortgage of <b class=\"lidd_mc_b\">{total_amount}<\/b> amortized over <b class=\"lidd_mc_b\">{amortization_years}<\/b> years and <b class=\"lidd_mc_b\">1<\/b> week, your <b class=\"lidd_mc_b\">{payment_period}<\/b> payment is","syw_text":"For a mortgage of <b class=\"lidd_mc_b\">{total_amount}<\/b> amortized over <b class=\"lidd_mc_b\">{amortization_years}<\/b> years and <b class=\"lidd_mc_b\">{amortization_weeks}<\/b> weeks, your <b class=\"lidd_mc_b\">{payment_period}<\/b> payment is","mp_text":"Mortgage Payment","tmwi_text":"Total Mortgage with Interest","twdp_text":"Total with Down Payment"};
/*  */</script> <script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/jqueryui/1.12.1/jquery-ui.min.js?ver=1.12.1' defer></script> <script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/jqueryui-touch-punch/0.2.3/jquery.ui.touch-punch.min.js?ver=0.2.3' defer></script> <script type='text/javascript'>/*  */
var genesis_responsive_menu = {"mainMenu":"Menu","subMenu":"Submenu","menuClasses":{"combine":[".nav-primary",".nav-header",".nav-secondary"]}};
/*  */</script> <script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.6/js/bootstrap.min.js' defer></script> <script type='text/javascript'>/*  */
var tve_dash_front = {"ajaxurl":"https:\/\/www.blownmortgage.com\/wp-admin\/admin-ajax.php","is_crawler":""};
/*  */</script> <script type="text/javascript">/**/if ( !window.TL_Const ) var TL_Const={"security":"02592abcde","ajax_url":"https:\/\/www.blownmortgage.com\/wp-admin\/admin-ajax.php","forms":[],"action_conversion":"tve_leads_ajax_conversion","action_impression":"tve_leads_ajax_impression","ajax_load":0,"main_group_id":8423,"display_options":{"allowed_post_types":[],"flag_url_match":false},"custom_post_data":[],"current_screen":{"screen_type":4,"screen_id":9201},"ignored_fields":["email","_captcha_size","_captcha_theme","_captcha_type","_submit_option","_use_captcha","g-recaptcha-response","__tcb_lg_fc","__tcb_lg_msg","_state","_form_type","_error_message_option","_back_url","_submit_option","url","_asset_group","_asset_option","mailchimp_optin"]}/* */</script><script src="https://www.blownmortgage.com/wp-content/cache/min/1/1b05be5af272ec123837d0148c251dcd.js" data-minify="1" defer></script><script src="https://www.google.com/recaptcha/api.js?onload=recaptchaCallback&render=explicit" data-minify="1" defer></script></body></html>
